Centroid M Series Post

I run BobCAD V33 currently. When I post to a file; on the first line, before the “%” sign, I get three characters added.
The first character is an i with a umlaut (2 dots over the i).
The second character is “>>”
The third character is an upside down question mark

The code will not run with these characters. They are not visible unless the file is used in an editor that allows you to see hidden characters (like Predator)

Is there a way to modify the post process so that these characters are not added?

seems to be some sort of character encoding issues.

  • have you always had the problem with this post processor?
  • did you try to use another post processor and look into that generated G code file to see the same behaviour?
  • can you upload a sample?

Bye, Harald

Hi jwlustig,

Please disable the Unicode support question in the postprocessor.
228. Support Unicode Output? n

Hope this helps.

1 Like

Hi @Claudia,
good point.
I’ve searched the common PP-Docus with terms like ‘encode’, ‘character’, … but failed to do in BobCAD-CAM_Post_Processor_Help_System :disappointed_relieved:

here’s the closer information which Claudia fortunately knew

Regards, Harald

Claudia beat me to it, but most likely the Unicode output is turned on for some reason.

99% of cases this unicode support should be turned off, but it needed to be added for our friends on the other side of the earth, as most CNC controllers do not support unicode but special provisions have occurred on some machines specifically for the Japanese market so they can have comments in their NC programs.


Thank you for your suggestion. When I opened the post processor to make that change I discovered that 228 was already set to n.

This is what see when I post.

coming back to my first question

further on

  • which post processor?
  • is the pp an original one or did you/someone (already) change it?

Bye, Harald

I have always had this problem. I am using the Centroid_M_Series post processor.
Here is the same thing using the Mach3 Post processor:
( DATE-THU. 01/13/2022 ,TIME-01:59PM)
( POST- Mach3 )

G00 G20 G90 G17 G40 G80 G49 G64 G94

what happens, if you do “Create NC code”, then select the whole G-Code do a copy/paste in an extern editor, store the code, close the extern editor and reopen the code (in different editors)?
Bye, Harald

I tried your suggestion. It worked, the characters didn’t come across. So that would suggest that the issue is in the “Post and Save As” action within Bob CAD wouldn’t it?


another test: do “Create NC code”, then right click in the Posting pane and save the G-Code. Inspect the G-Code with extern editors. Let’s see what it does.
Regards, Harald

No Special Characters!
; DATE - THU. 01/13/2022
; TIME - 03:25PM
; JOBSETUP[LocoGridPocket_1122022.mwjs]JOBSETUP

N01 M25 G49
N02 G17

that’s interesting. Seems you have found a bug, as on my BCV34 it behaves the same. I didn’t recognize so far, because in normal text editing mode those unicode characters are not visible. But yes, % are also generated on my machine but only with “Post & Save”. Just doing “Post” and saving from the Posting pane no unicode characters are given. Also, if doing a Copy/Paste there are no unicode characters.

I think, this should be checked from BC-team in more detail.
Bye, Harald

I just use the BC 3x mill post for my Centroid machines…

@WeekendWarrior: sorry, didn’t catch the point. Do you have the same behaviour with BC 3x mill or what is your info about?
Bye, Harald

Sorry for the delay in testing it Harald.
I just tried posting using BC_3x_Mill. No hidden characters.

So for now it appears to be isolated to the Centroid version but now I have 2 work arounds.
Thanks for everyones help and suggestions