Migrate vom BC4RHV1 to BC4RHV2 and/or using both in parallel


having some time I started to install BC4RHV2. I thought it should be possible to have both version (V1 and V2) running in parallel. Each installs in separate folders and also it does with the data stuff.

So I just disabled BC4RHV1 and closed Rhino before installing BC4RHV2. After installation, Rhino throws following message when starting it.

Looking into the Plug-In List, there is no BobCAM at all:

So I tried to uninstall BC4RhV1 (leaving Data Folder). But still no BobCAM plug-in is shown.

Next I run the install process again using the Repair mode. Had no luck at all. Starting Rhino it always detect a new plug-in
ending in the error message shown first in this topic.

So I uninstalled BC4RHV2 having no BC4RH at all. Just the standalone versions V32, V33 and V34 remains.

Starting Rhino again, the error message are gone. Well, at least this worked :slight_smile:

Yes, you know already the next step: installing BC4RHV2 again.
Installation did the way it should. Sadly, loading the plug-in fails with same behaviour explained above. BobCam still isn’t in the list of plug-ins :frowning:

My last decision was to uninstall BC4RHV2 and reinstall BC4RHV1. No chance. This also didn’t work. No BobCAM plug-in listed, failure during Rhino start and at all having no BobCAM in Rhino anymore :frowning:

Hope, BC can help out of this.
Bye, Harald


got my BC4RHV1 back:

I used the “Install…” button on Rhinos plug-in manager and run BobCAMRhino.rhp stored in the “C:\Program Files\BobCAD-CAM\BobCAM for Rhino V1” folder.

I’ll give it a try with BC4RHV2 now…

Bye, Harald


I did just the installation of BC4RHV2 again. Rhino again throws the “Unable to load BobCAMRhino.rhp” message. Within PlugInManager, also no BobCAM is listed anymore.

So within the PlugInManager I hit the “Install…” button again and choose “C:\Program Files\BobCAD-CAM\BobCAM for Rhino V2\BobCAMRhino.rhp” to get installed. After a short time I got the Registration Wizard :slight_smile:

and after doing the registration :smile:

Maybe I’ll try the whole thing again with BC4RHV1?! Or rather not …

All in all you all get an idea how to fix it, when running into the same issues :wink:
Bye, Harald

Hey Harald!

Thank you so much for your thorough feedback. We have been able to reproduce the issue with the steps you provided and are looking into why disabling BCR V1 first causes any issues.

In general, just having Rhino closed and then running the installer for BCR V2 will install it properly and handle everything, but it seems having BCR V1 installed and disabled causes something to occur which we are looking into.

Also to note, you cannot run BCR V1 and BCR V2 simultaneously within the same version of Rhino. You can however say run BCR V1 in Rhino 6 and run BCR V2 in Rhino 7. Rhino manages the plug-in loading independently between versions.

It’s also important to note that BCR is set to only load When Needed so that BCR is not force started every time you launch Rhino. Rhino manages this, so whenever you use a BCR command it’s not until that time that BCR is loaded into memory or if you open a document that has BCR data inside then Rhino will load the plug-in.

The other common confusion we are seeing with customers is Rhino’s compatibility check that it runs the first time a plug-in is loaded. They display a progress bar in the status bar the first time it loads which takes a little time, and it seems common so far that people are overlooking this step and think things aren’t working while Rhino runs that check.

We will return with some findings after investigating why disabling BCR V1 first causes any problem with BCR V2 loading.