Predator Editor

I upgraded my computers to windows 10 and now my predator editor does not come up when I click on the edit button in V-30. How do I fix it?

I have similar problem my Predator 2005 version won’t even open up. It worked perfectly fine until Microsoft loaded an update. They updated there antivirus system and change everything around it became where some of my software would not open. I fixed a lot them which allowed me pass by going into the program. This is how I navigate at my end. (1) Windows security (2) virus & threat protection (3)virus & threat protection settings(4)Manage Settings(5)Scroll down to Control folder access (6) click on manage folder access (7) Choose allow an app through folder control folder access (8) choose add allow app (9) find the exe. file of specific program choose it. You may have to load several exe. extensions and depends on many are the in the program. Although this may not work with Predator it didn’t work at my end because Predator has msi. extension at my end. But my NC Editor worked fine after choose exe. extension. This in my opinion Microsoft issue. Why say this Predator worked fine before the update. I don’t know if Predator has a exe. extension. I wasn’t able to find one. I did a repair and no joy!! I use Predator in v.31. Anybody has a solution please offer?

Call Tech Support. They got me up and running with predator. My old machines do not like the NC editor.

Got news for you guys since my last post I mention Predator doesn’t work with my W10 Pro 21H2.

Now new problem occurred in my version 30 build 2015. which I cannot generate g-code. I did request support which they were unable fix. So V30 is unusable to make code. This is kind thing that cripple a company.

Hello Everyone,

I am not sure what caused your Predator Editor to stop working. However, there is an easy way to get it back up and running. That is to download and install V24 linked below (You do not need to register it)

Here is a link to download the V24 software:

Just copy and paste the link above into your internet browser. When it finishes downloading you can run it like a normal install and let it install the Predator Editor.

If it doesn’t automatically install the Predator then go to “C:\BobCAD-CAM Data\BobCAD-CAM V24\System Files” and Double-Click “Predator CNC Editor 2005 for BobCAD”

That will start the installation for the Predator. Then, launch Predator from the Edit CNC button inside of V30 and it should open if it was installed properly.

As for V30 not producing G-Code, you will want try a couple of things:

  1. Check the software dependencies to make sure your computer has all the necessary dependencies here: BobCAD-CAM Installer Dependencies - BobCAD Support

For Posting, the important one is that you have C++ 2010 x86 – 10.0.30319 (Or newer build) on the computer. If not, you can download the x86 one here: Download Microsoft Visual C++ 2010 Service Pack 1 Redistributable Package MFC Security Update from Official Microsoft Download Center

  1. If that doesn’t work I would try a complete uninstall/reinstall of the software. (Make sure to Transfer the license off the software first so that you can reregister when done. Go to Help > Transfer License in BobCAD) Then, once you try opening the installer, make sure to right-click on it first and select “Run As Administrator”.
    It sounds like this may be more of a computer issue, if installing the C++ didn’t work. So, you want to make sure you have all permissions required to install everything properly on the computer. I have even had to go as far as to load the default Admin account on the Windows computer to install the software that way because the computer wasn’t installing BobCAD properly (How to Enable or Disable the Administrator Account in Windows).

Anyways, hopefully this helps everyone out! You can always give us a call or email if you ever need any further help and we help to assist! Support number: (727) 489 – 0003 or

maybe this will help, see attachment
Prederror.pdf (18.4 KB)
all what describe is within the parameters. according to Microsoft the program is to old.
clean install help to a degree in 31 has no Predator. maybe run this pdf up to the developers